Netflix API Forums

API Forum

RSS Feed

Major issue: getting 500 internal server errors when

    • dhchoi
    • Topic created 5 years ago

    It's worked before, but starting last night I've been getting 500 internal server errors during the authorization step, when my API consumer application redirects the user to the Netflix page where they authorize the application to access their Netflix account. E.g.:

    https://api-user.netflix.com/oauth/login?application_name=instantwatcher&oauth_callback=http%3A%2F%2Flocalhost%3A3001%2Fiphone%2Fusers%2Fcomplete_authorization&oauth_consumer_key=MY_API_KEY_HERE&oauth_token=wvppgsf3nhvkjup4urbm7jpx

    The response I get for this type of request is no longer the standard Netflix webpage but a 500 error:

    <status>
    <status_code>500</status_code>
    <message>Internal Error</message>
    </status>

    I'm wondering if others are having the same problem. If so, this is pretty serious, as it is preventing new users from going through the OAuth authorization process.

    Thanks for your attention to this,

    Dan (instantwatcher.com)

    Message edited by dhchoi 3 years ago

    Tags

  1. raghus5 years ago

    Same here on FeedFliks.com (fwiw, existings users data can be refreshed...)

    No new users are able to register from about 11pm PST last night.

    qflip.net also seems to be not working so it's likely something on your side

  2. John McLaughlin5 years ago

    I'm seeing it on my app movieflick also…..

  3. priya5 years ago

    Guys, we have had this report from a few of our developers, we are looking into this issue right now to see what's changed since yesterday and what's causing this. Sorry for the inconvenience. We will keep you posted.

  4. priya5 years ago

    Thanks for sending this to us, we are looking into this.

  5. dhchoi5 years ago

    If you guys could put up a temporary "Out of Order" page at the problematic URL (https://api-user.netflix.com/oauth/login) in the meantime -- or redirect to one -- that would help a lot.

  6. mikey5 years ago

    We have identified the problem; some code for oath 1.0a got pushed when it shouldn't have. We have a fix, and should be deploying asap. Sorry about this!!

    =-mikey-=

  7. raghus5 years ago

    I second Dan's idea - something on the lines of a "Out of Order" page would be great

  8. Dan Hinsley5 years ago

    Any ideas on when this might be fixed?

  9. Michael Hart5 years ago

    The servers are being fixed right now. You can follow updates on the netflixapi twitter account.

  10. raghus5 years ago

    It seems partially fixed...

  11. dhchoi5 years ago

    API Team: thank you for your rapid response and hard work. It seems to be working now.

  12. Michael Hart5 years ago

    No problem. Sorry for the outage, but this issue slipped though our regression tests. BTW, we usually post real-time updates on issues like this to the netflixapi twitter account.

  13. raghus5 years ago

    I wonder if I am the only one who's getting timeouts and overall sluggishness of the API
    For example I've gotten a bunch of these:
    Errno::ETIMEDOUT: Connection timed out - connect(2) at 01-Oct-09 23:51:49
    and for calls that are going through are taking 20-25s rather than the usual 1 sec or so.

    Anyone else seeing this?

  14. raghus5 years ago

    I even tried with Flixo+Firefox to make sure it isn't my code - and even Flixo times out.

    Can someone look at this and let us know?

    Thanks!

  15. raghus5 years ago

    seems ok now. thanks

  16. dhchoi5 years ago

    I'm noticing some API sluggishness as well.

  17. dhchoi5 years ago

    Yes, I've been seeing some timed out API requests as of 6 minutes ago.

  18. Dan Hinsley5 years ago

    Yep, things are really crawling, and sometimes not accessible at all. Are you guys still working on this?

  19. Dan Hinsley5 years ago

    Looks like maybe it's working again.

  20. Dan Hinsley5 years ago

    Nope, still getting timeout's and internal server errors.

  21. Michael Hart5 years ago

    A backend storage failure took a number of systems down temporarily. When the issue was addressed the servers got pounded by the waiting clients (this is our peak load period). We have ways of getting the spike to ease off that were employed in the last few minutes, the spike is subsiding and the API is responsive again.

  22. dhchoi5 years ago

    Thank you

  23. AspreyJ3 years ago

    I know this was 1 year ago, but I'm getting "internal error" messages and netflix won't work.
    I've powered off and on the roku and reset it twice.
    nothing.
    I've played other streaming video just fine, but not netflix. Ex: Crackle and Blip.tv
    What's going on?

  24. Cyrus Najmabadi3 years ago

    I'm also getting these messages and they're affecting all my users. Please let me know what's up here. Thanks!

[ Page 1 of 1 ]

New posts are not allowed