Netflix API Forums

I Need Help!

RSS Feed

can't reorder instant queue

    • elaydin
    • Topic created 4 years ago

    This isn't as important as the 2 issues I've commented earlier, but I don't seem to be able to reorder the instant queue anymore.
    This used to work (and still does for DVDs):
    http://api.netflix.com/users/XXXXXX/queues/disc?title_ref=http://api.netflix.com/users/XXXXX/queues/disc/available/4/70105370&output=json&position=3&method=POST

    the response i get is

    {"status": {
    "message": "Internal Error",
    "status_code": 501
    }}

    on the other hand, this works fine for DVDs
    http://api.netflix.com/users/XXXXXX/queues/disc?title_ref=http://api.netflix.com/users/XXXXXX/queues/disc/available/4/20371374&output=json&position=3&method=POST

    Message edited by elaydin 2 years ago

  1. nitramssirc4 years ago

    I can confirm that I'm seeing the exact same behavior.

  2. Nicholas Clarkson4 years ago

    I've always used the movie's title_id and not its queue id.

  3. elaydin4 years ago

    looks like i cut and pasted the same thing twice in my original note. Point still stands, but the instant url is:
    http://api.netflix.com/users/XXXXXXX/queues/instant?title_ref=http://api.netflix.com/users/XXXXXXXX/queues/instant/available/6/523650&output=json&position=5&method=POST

  4. arothian3 years ago

    I'm having the same issue. I can reorder disc queue but instant queue returns status code 501 reason Not Implemented

  5. nitramssirc3 years ago

    Does anyone know if there is a more direct line of communication with Netflix about api issues than just posting in the forum. It seems to me that they don't monitor this forum nearly as much as they did a year or so ago.

  6. wade3 years ago

    Yep, exact same thing here. Status code "(501) Not Implemented."

  7. elaydin3 years ago

    This seems to be back again.
    Noticed it tonight when I was about to reenable it in my app.
    Same error:


    {"status": {
    "message": "Internal Error",
    "status_code": 501
    }}

  8. elaydin3 years ago

    works again... good times

  9. Nicholas Clarkson3 years ago

    This appears to be broken again for just the Instant queue. Receiving 501: Not Implemented. Anyone else seeing this?

  10. Nicholas Clarkson3 years ago

    Am I really the only one seeing this again?

  11. Jeff Dillon3 years ago

    Hi

    I just tested this, and it's working for me. Are you getting an error? Can you post your request here?

    Jeff Dillon, Netflix API Support

  12. Nicholas Clarkson3 years ago

    This worked 2 days ago and still works with the disc queue. I have tried both with and without the etag.

    http://api.netflix.com/users/USER_ID/queues/instant?title_ref=http%3A%2F%2Fapi.netflix.com%2Fcatalog%2Ftitles%2Fmovies%2F70118402&position=2&method=POST

    <status>
    <status_code>501</status_code>
    <message>Internal Error</message>
    </status>

  13. elaydin3 years ago

    I'm seeing the same error (again). This has been working on and off for me for the last few weekes. I know there have been times when it has been working for me, but not for others (and probably vice versa). The information is in my original post.

  14. Jeff Dillon3 years ago

    Hi,

    I will investigate further, and post more information here. Does this error occur on the first move, or subsequent attempts soon after (within 30 seconds, for example)?

    thanks

    Jeff Dillon, Netflix API Support

  15. elaydin3 years ago

    seems to happen on all of them. Works fine for DVDs though.

  16. zacharski3 years ago

    We are getting a 501 error on this as well for the Instant Queue when reordering. DVD queue works correctly.

  17. Jeff Dillon3 years ago

    Hi

    Is this on the first move? Or subsequent moves? I too get an error if I try to make a move within ~60 seconds of the previous move. Are you still seeing this issue? Is this on a Windows client? If so, might you be able to provide a Fiddler trace? (http://www.fiddler2.com, configure for HTTPS under Tools/Fiddler Options). Or provide the REST call details? To provide sensitive information, please email directly to apisupport@netflix.com, please keep general questions on the forum.

    Thanks

    Jeff Dillon, Netflix API Support

  18. Jeff Dillon3 years ago

    Hi

    Here is the URL that is working for me:

    http://api.netflix.com/users/nnnnnnn/queues/instant?etag=183166735&oauth_consumer_key=nnnnnn&oauth_nonce=3856299&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1303687520&oauth_token=nnnnnnnn&oauth_version=1.0&position=1&title_ref=http%3A%2F%2Fapi.netflix.com%2Fcatalog%2Ftitles%2Fmovies%2F1046268&oauth_signature=nnnnn

    Jeff

  19. elaydin3 years ago

    Jeff,
    Still no luck. I've posted my url above. I tried with and without the etag. I've tried using the title id instead of the queue id. I've tried the title id with etag.
    All get the 501 (yet they all work for DVDs)
    I've never actually seen the ~60 second issue you keep mentioning.
    I'll try to gather some info to email you guys.

  20. Nicholas Clarkson3 years ago

    Not sure if it is related but while I can add a title to the Disc queue at any position with the Instant queue I can only add a title at the bottom (the default w/o a position) or at the top (position=1). Giving any other position just adds the title to the bottom.

    Also, regarding the URL Jeff gave: Without method=POST won't this call just display the Instant queue?

  21. boozedog3 years ago

    I'm seeing same problem as the others -- (501) Not Implemented. I can reorder DVD queue but not instant queue.

    This works:
    http://api.netflix.com/users/xxxxx/queues/disc?handleAs=xml&method=POST&oauth_consumer_key=xxxxx&oauth_nonce=fe2f7e9714bd4ec48d652a32645d72c1&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1303781005&oauth_token=xxxxx&oauth_version=1.0&position=1&title_ref=http%3A%2F%2Fapi.netflix.com%2Fcatalog%2Ftitles%2Fmovies%2F70077923&oauth_signature=xxxxx

    This doesn't:
    http://api.netflix.com/users/xxxxx/queues/instant?handleAs=xml&method=POST&oauth_consumer_key=xxxxx&oauth_nonce=fe2f7e9714bd4ec48d652a32645d72c1&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1303781005&oauth_token=xxxxx&oauth_version=1.0&position=1&title_ref=http%3A%2F%2Fapi.netflix.com%2Fcatalog%2Ftitles%2Fmovies%2F70077923&oauth_signature=xxxxx

  22. Jeff Dillon3 years ago

    Hi

    @Nicholas, I am actually using an HTTP POST, so the method=POST is not required. I am also able to use a GET with the method=POST without error. For users continuing to get this error, please send a network trace using a tool similar to Fiddler (http://www.fiddler2.com). Turn on HTTPS decryption under Tools/Fiddler Options. Please send the trace to apisupport@netflix.com

    Thanks

    Jeff Dillon, Netflix API Support

  23. elaydin3 years ago

    Jeff,
    Sent you a note with what I think you wanted (though this is the first time using the network tool).

  24. ShyanMing Perng3 years ago

    Getting the same instant queue move error as others for the "CineTap for Netflix" app.
    Here is an example wireshark trace

    GET /users/T1jK_oSUFhts8QhKldEnkcz7AB8aAtJPfB7rtH6_fR1iI-/queues/instant?v=2.0&method=post&position=1&etag=1581760191060&title_ref=http%3A%2F%2Fapi.netflix.com%2Fcatalog%2Ftitles%2Fmovies%2F555221 HTTP/1.1
    Host: api.netflix.com
    User-Agent: CineTap/3.0.4 CFNetwork/485.13.8 Darwin/10.6.0
    Authorization: OAuth realm="", oauth_consumer_key="ejvfwmrmvx2qpvsfaty5hat8", oauth_token="BQAJAAEDED7YwQn_JYxxvG3SYchdptkwHmJVsEtQtL5vDCKSiqAjs3ke1fKNAyZUOzq9tOg91inMC6kL14o-alw4tMGbj7y5", oauth_signature_method="HMAC-SHA1", oauth_signature="cDYQDUZ0q6WRBFKw0kwDd%2F%2Fs66Y%3D", oauth_timestamp="1303791028", oauth_nonce="FA038013-9128-4563-9573-C3C30007927A", oauth_version="1.0"
    Accept: */*
    Accept-Language: en-us
    Accept-Encoding: gzip, deflate
    Cookie: NetflixShopperId=GA-a7925b55-e88b-4056-a3e4-86657744407c
    Connection: keep-alive

    HTTP/1.1 501 Not Implemented
    Content-Encoding: gzip
    Content-Type: application/xml
    Date: Tue, 26 Apr 2011 04:10:28 GMT
    Server: Noelios-Restlet-Engine/1.1.rc2
    Vary: Accept-Encoding
    X-Mashery-Responder: proxyworker-i-5b380930.mashery.com
    X-Netflix.client.instance: i-829bd1ed
    Content-Length: 100
    Connection: keep-alive

    <?xml version="1.0" standalone="yes"?>\n\n<status>\n <message>Internal Error</message>\n</status>

[ Page 1 of 2 | Next ]

New posts are not allowed